file Question Micro tool length sensor problems

  • briansone
  • briansone's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
06 Jun 2017 14:08 - 06 Jun 2017 14:10 #47926 by briansone
Micro tool length sensor problems was created by briansone
Stepcraft included the micro tool length sensor with my 300 machine & can't find much/anything about it anywhere on the Stepcraft site.

I've installed as per the non-micro (normal) tool length sensor instructions including all the software side but:
- when i click the sensor button in UCCNC it says 'the probe sensor was active. The operation was aborted."

I can only get the z-axis to plunge when i manually depress/hold down the tool length sensor button, then it stops plunging when I release the button = inverted behaviour.

I changed switched the wiring, not knowing if that could be the problem but same behaviour still.

Any ideas why my micro tool length sensor's behaviour is inverted?
Last edit: 06 Jun 2017 14:10 by briansone.

Please Log in or Create an account to join the conversation.

More
06 Jun 2017 14:24 #47928 by DocBrown
Replied by DocBrown on topic Micro tool length sensor problems
Didn´t understand what you exactly have done... but have look on page 26 of the UCCNC manual: UCCNC

I think you have to set the probe pin to "active low", than "Apply" and save. Next start check if the change was stored, if not you have to save the new UCCNC configuration with a different file name (page 39) since the default profile is normally write proteced in Win.

Viele Grüße

Hartmut
V2/420 China 800W wassergekühlt
UCCNC & ARDUINO ESTLCAM Controller
ESTLCAM & QCAD
DK5LH/G11

Please Log in or Create an account to join the conversation.

More
06 Jun 2017 14:33 #47929 by DerRoy
Replied by DerRoy on topic Micro tool length sensor problems
1.)
Which version of UCCNC are you using?
If it is not the actual version 1.2037 pls download it here: cncdrive.com/UCCNC.html
One of the older version had a bug.

2.)
If you use a handwheel, you need to switch it of in the software before you start the probing.
Just click in the Jog Screen on Continous.

MfG
Roy

SC 600/2; SolidWorks; UCCnC und UC100; EstlCam und Arduino Steuerung; KRESS 800kfme;

Please Log in or Create an account to join the conversation.

  • briansone
  • briansone's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
06 Jun 2017 16:19 #47931 by briansone
Replied by briansone on topic Micro tool length sensor problems
I'm using 1.2037.

& setting probe pin to 'active low' fixed it.

New problem though, i missed the sensor button by a mm, it pierced the micro tool length sensor & now it's no longer clickable... broken... ffs. i've added the photo. v disappointed.

This message has an attachment image.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

More
01 Nov 2019 01:56 #57582 by ACNC
Replied by ACNC on topic Micro tool length sensor problems
Same trouble with my sensor.
I wonder if the sensor send a signal.
It's well plugged but no signal on the diagnostic window.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

© 2019 STEPCRAFT GmbH & Co. KG