file Question Fräse bewegt sich, doch Spindel bleibt still

  • MR9000
  • MR9000's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
09 Jan 2019 15:36 #55647 by MR9000
Hallo,

ich habe mich angemeldet weil ich ein Bedienproblem mit meiner Fräse habe.

Ich habe eine gebrauchte Stepcraft420 welche mit WINPC-NC USB angesteuert werden soll. Als Programm nutze ich Fusion360. Als erstes Beispiel soll einfach die Opferplatte mit 0,5mm plan abgetragen werden. Da die Probleme dort schon anfingen, habe ich eine Beispieldatei erstellt, einen 12x12cm mit 1cm Höhe, in dem mittig ein 10x10cm "Becken" mit 0,5mm Tiefe eingetragen ist, wodurch die Planierung der großen Opferplatte erstmal in klein nachgestellt werden soll.

In Fusion funktioniert die Simulation gut, den WINPC-Postprozessor habe ich ebenfalls heruntergeladen.

In WINPC die Datei eingelesen ergibt auch dasselbe "Schnittmuster" wie in der Simulation in Fusion. Den Nullpunkt irgendwo auf die Opferplattenoberfläche setzen und dann das Programm anfahren funktioniert auch soweit was die Maße angeht, nur: Die Spindel bleibt absolut still stehen.

Im manuellen Modus fahren und die Spindel anschalten funktioniert ohne Probleme.

Die ersten Zeilen des G-CODE lauten:
%
(1001)
(T1  D=3. CR=0. - ZMIN=-0.5 - Schaftfraser)
N10 G90
N11 G71

(2D Adaptive2)
(CHANGE TOOL)
N12 T1 M06 (SCHAFTFRASER D=3. DIAMANTVERZAHNT 3MM)
N13 M03 S20000
N14 G54
N15 G00 X60.044 Y61.424
N16 G00 Z-15.
N17 G00 Z-5.
N18 G00 Z-2.55
N19 G03 X59.956 Y58.575 Z-2.394 I-0.044 J-1.424 F333.3
N20 G03 X60.044 Y61.424 Z-2.237 I0.044 J1.424

Nach Zeile N13 müsste er die Spindel dort doch anfahren?

Lese hier schon fleißig mit und freue mich auf Hilfe.

Viele Grüße

Please Log in or Create an account to join the conversation.

More
10 Jan 2019 09:00 #55669 by Rahul
Welche Spindel verwendest du?
Ist der Ausgang in Winpc-NC richtig konfiguriert?
Ob die Spindel eingeschaltet wird, kannst du auch manuell über den Signaltest-Dialog ausprobieren.

Fräse: SC 2/840 USB, Proxxon IBS/E STEPCRAFT HF-500, Werkzeugwechsler + WZLS + T-Nutentisch
3D-Drucker: MendelMax 1.5
CAD: Designspark Mechanical, Eagle
CAM: Estlcam V9, DeskProto
The following user(s) said Thank You: MR9000

Please Log in or Create an account to join the conversation.

  • MR9000
  • MR9000's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
10 Jan 2019 13:14 #55679 by MR9000
Vielen Dank für die Hilfe!

Spindel ist dieses Chinamodell:
https://www.amazon.de/Luftgek%C3%BChlten-Spindelmotor-Spindle-controller-Gravieren/dp/B01KJRARZ6


Es scheint wirklich am Ausgang zu liegen.

Bei manuellem Fahren dreht sich die Spindel einwandfrei:

This image is hidden for guests.
Please log in or register to see it.



Erst Kühlung aktivieren (obwohl keine vorhanden), dann Spindel und er dreht mit der Spindeldrehzahl standard aus den Grundeinstellungen.

Im Signaltestmenü sind der Spindel und der Kühlung folgende Ports zugewiesen:

This image is hidden for guests.
Please log in or register to see it.


Stimmt überein mit den Grundeinstellungen unter Spindel (Port 17 ist der Port für die Drehzahl-PWM).

Wenn ich im Signaltestmenü dann allerdings wie beim manuellen Fahren erst Kühlung aktiviere (Port 14) und dann die Spindel (Port 1), tut sich auch nichts.

This image is hidden for guests.
Please log in or register to see it.



Etwaiges zuschalten der PWM (Port 17) in allen möglichen Reihenfolgen führt auch nicht zur Aktivierung der Spindel.

Woran könnte das liegen?


Und noch eine Verständnisfrage: Ich gebe die Werkzeugparameter (vorerst nur ein Fräser ohne Wechsel) alle über Fusion in die CAM ein, muss ich diese Daten noch genauso in WINPC einpflegen oder übernimmt er die?

Viele Grüße

Please Log in or Create an account to join the conversation.

  • MR9000
  • MR9000's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
14 Jan 2019 08:35 #55721 by MR9000
Ich konnte das Problem lösen, indem in Fusion bei der Werkzeugauswahl zusätzlich die (nichtvorhandene) Wasserkühlung ausgewählt wurde.
Danke für die Tipps!

Please Log in or Create an account to join the conversation.

More
14 Jan 2019 17:12 #55727 by Stepomat
Replied by Stepomat on topic Fräse bewegt sich, doch Spindel bleibt still
also so ein Müll an Spindel würde ich mir nie kaufe dafür sin 95€ zuviel allein die Angeflanschte ER 11 Spannhüllse die dann auch nur von einer Madenschraube Gehalten wird....
das teil hat noch nicht mal ein CE zeichen ...
Sorry aber irgendwo hört doch der geiz ist geil Faktor auf

MFG oliver

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

© 2019 STEPCRAFT GmbH & Co. KG