heart Question Yet another DL445 Set Up Question - UCCNC

  • WMorton
  • WMorton's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
25 Mar 2020 18:17 #58576 by WMorton
Hi All,

I acquired a DL445 laser module a while back and since we are currently in COVID19 lock-down, I thought now would be a great time to set it up!

I have a Stepcraft 840, UCCNC and am using the default Stepcraft laser profile. The DL445 module is plugged directly into the Stepcraft machine (not via a switch box or anything).

The issue I am having is ... well ... nothing happens! The fans on the control box and the fan on the laser power up. But thats it. I can't get the height probe to trigger, the status LED to light nor the laser to switch on. I've checked the pin assignments which all look OK in the configuration pages in UCCNC. I can get the status LED to come on if I change the laser pin (pin 17) on the i/o set up to pin 1. But that's as far as I've got.

Should I be able to see the status of the height probe on the diagnostics page?
Should there be a pointer type light on the Laser for zeroing?

Any help would be greatly appreciated! Going a little crazy with being in lock down and a problem I can't fix!!!

Please Log in or Create an account to join the conversation.

More
26 Mar 2020 16:52 #58597 by andileibi
Replied by andileibi on topic Yet another DL445 Set Up Question - UCCNC
Hello, I had the same problem.
A long story in short, SC sells a laser for 550€ and is not able to add a working UCCNC screenset.
Fakt is, with the original SC screenset you are not able to run the laser because you cannot set all settings
I got help in this foum:
www.forum.cncdrive.com/viewtopic.php?f=2&t=2322&start=0
Here you can see how to cange the screenset.
The following user(s) said Thank You: WMorton

Please Log in or Create an account to join the conversation.

  • WMorton
  • WMorton's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
26 Mar 2020 19:17 #58601 by WMorton
Replied by WMorton on topic Yet another DL445 Set Up Question - UCCNC
Hi Andileibi,

Thank you for the reply. However, I think it is a different issue as I can set the current hi/low on the i/o setup page. I am using the newest Stepcraft screenset which seems to have to option available.

Do you have any other ideas?

Thanks,
Wayne

Please Log in or Create an account to join the conversation.

  • WMorton
  • WMorton's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
26 Mar 2020 19:56 #58602 by WMorton
Replied by WMorton on topic Yet another DL445 Set Up Question - UCCNC
YOU WERE RIGHT!

Thank you so so much. I have wasted hours on this issue. And thank you to dezsoe on cncdrive. I am still having issues with the probe pin but I suspect that is the same issue. I will investigate.

Thanks,
Wayne

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

© 2020 STEPCRAFT GmbH & Co. KG