question-circle Frage UCCNC und manueller Werkzeugwechsel

Mehr
26 Nov 2018 13:55 #55261 von Sirius28
COM_KUNENA_MESSAGE_CREATED_NEW
Hallo zusammen,

an dieser Stelle hoffe ich mal wieder auf Eure Hilfe. Gestern hatte ich ein Problem mit UCCNC. Ich hatte über Estlcam eine Fräsdatei erzeugt, in der zwei manuelle Werkzeugwechsel vorkommen, bei denen ich jeweils Fräser mit unterschiedlichem Durchmesser einspannen möchte.

Soweit so gut, UCCNC startet den Fräsjob ganz normal mit dem ersten Fräser bis zu der Stelle an denen der erste Werkzeugwechsel ansteht. An der Stelle stoppt die Spindel dann auch, aber leider fährt die Z-Achse dann im Eilgang bis an den Referenzschalter nach oben und unterbricht dadurch natürlich das komplette Programm. Anschließend war es dann trotz Rückstellen des Rferenzschalters nicht mehr möglich, den Fräsjob mit dem zweiten Werkzeug auszuführen. Einzige Chance das Werkstück zu retten war dann, sich die erste Zeile nach dem Werkzeugwechsel zu merken, das kompletter Programm neu zu laden und dann ab der betreffenden Zeile mit dem zweiten Werkzeug wieder zu beginnen.

Das kann es doch eigentlich nicht sein, oder??

Woran könnte das liegen, bzw, welche Einstellungen müsste ich ggfs. ändern?

Vielen Dank für Euren Rat.

Viele Grüße

Christoph

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • FrankTi
  • FrankTis Avatar
  • Offline
  • Forum Nutzer
  • Forum Nutzer
  • Inkscape, Estlcam und UCCNC
Mehr
23 Dez 2018 11:03 #55469 von FrankTi
COM_KUNENA_MESSAGE_REPLIED_NEW
Hallo Christoph.

Seit einiger Zeit beschäftigt mich das Thema auch. Zwar nicht in dem Ausmass wie bei dir. Aber bei mir stopt die Spindel nicht, stellt die Drehzahl auf das nächste Werzeug ein und fräst weiter.
Möglich, dass ich in Estlcam etwas nicht richtig eingestellt habe. Bin eben kein Spezi. Ich habe hier aber trotz intensivem Suchen bisher keine Lösung dafür gefunden. Ich programmiere seit einiger Zeit die Jobs der Werkzeuge einzeln und starte sie nacheinander. Dafür gibts sicher eine einfache Art der programmierung.

Ich wünsche allen Stepcraftomanen ein schönes, friedliches Weihnachtsfest.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
23 Dez 2018 12:24 #55472 von ubo
COM_KUNENA_MESSAGE_REPLIED_NEW
Ein von Estlcam erzeugter Werkzeugwechsel sieht im Programm z.B. so aus:
T1 M06 S24000 (Wechsle Werkzeug: Fraeser 1mm)

Wenn eine ähnliche Zeile im Programm enthalten ist musst du den "Fehler" in deiner Steuerungssoftware suchen.

Hast du in Programm keine Zeile die mit "T" beginnt musst du die Einstellungen in Estlcam anpassen.

Gruß,
Uwe

WinPC-Nc V3, EstlCAM V11
www.cnc.kuckmalda.de
Folgende Benutzer bedankten sich: FrankTi

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • FrankTi
  • FrankTis Avatar
  • Offline
  • Forum Nutzer
  • Forum Nutzer
  • Inkscape, Estlcam und UCCNC
Mehr
23 Dez 2018 13:13 #55474 von FrankTi
COM_KUNENA_MESSAGE_REPLIED_NEW
Danke Uwe.
Da war ich wohl zu voreilich und hatte angenommen, dass UCCNC dann den Wechsel ermöglichen würde. Nö machts nicht, wenn das Häkchen an der falschen Stelle gemacht wurde. Bei den Allgemeinen Einstellungen war Befehl (M6) ignorieren angekreuzt. Ich hoffe mal, das war der Fehler. Nach den Feiertagen wird es überprüft.
Danke für den Schupser in diese Richtung.

Viele Grüsse Frank

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • FrankTi
  • FrankTis Avatar
  • Offline
  • Forum Nutzer
  • Forum Nutzer
  • Inkscape, Estlcam und UCCNC
Mehr
23 Dez 2018 14:20 #55475 von FrankTi
COM_KUNENA_MESSAGE_REPLIED_NEW
Es hat mir keine Ruhe gelassen. Den von mir in Estlcam geänderten Text für einen Werkzeugwechsel wieder in den Ursprungstext zurückgesetzt.
Dann zu NCCNC: Das Häkchen bei "Spindel anhalten und auf Zyklusstart warten" setzen, Diese Einstellung in UCCNC - Allgemeine Einstellungen speichern uuuuuuund ganz wichtig (hatte ich beim ersten Mal vergessen) EINSTELLUNGEN ANWENDEN Erst dann geht´s.
Dann werde ich mal meine bereits gespeicherten Projekte laden und mit den geänderten Einstellungen erneut speichern.
Danke nochmal.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • FrankTi
  • FrankTis Avatar
  • Offline
  • Forum Nutzer
  • Forum Nutzer
  • Inkscape, Estlcam und UCCNC
Mehr
01 Jan 2019 12:06 #55544 von FrankTi
COM_KUNENA_MESSAGE_REPLIED_NEW
Allen ein gesundes neues Jahr und viel Erfolg und Spaß beim Spänefabrizieren.


So heute habe ich mal einen Test gefahren, nach dem ich die Einstellungen, wie oben beschrieben, geändert hatte. Aber es gab keine Reaktion beim geplanten Wechsel. Der Haken war in den Einstellungen wieder auf Ignorieren gesetzt, obwohl ich gespeichert und aktiviert hatte.
Gibt's dafür eine Erklärung oder wo muss ich diese Einstellungen noch sichern?


Gruß Frank

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Powered by Kunena Forum

© 2018 STEPCRAFT GmbH & Co. KG