Suche
Lieber Nutzer, die Forumssoftware wurde aktualisiert. Für die Erstanmeldung musst Du bitte dein Passwort zurücksetzen.
Dear user, the forum software has been updated. For the first login please reset your password.
Specific move causi...
 
Benachrichtigungen
Alles löschen

Specific move causing step loss on D-420 when cutting nothing but air.

3 Beiträge
2 Benutzer
0 Likes
915 Ansichten
(@ssozonoff)
Beiträge: 2
New Member
Themenstarter
 

Hi,

I have generated a pocketing operation using Fusion 360 and GCode using WinPC-NC post processor.
When I run the GCode through WinPC-NC cutting nothing but air I consistently get step loss always at the same spot. (seemingly on X and Y axis)
I have tried slowing down transition feed rate and it does not seem to make any difference. When the step loss occurs I do hear a rather unpleasant noise. The way I test this is to Home the machine, send it to origin, run the GCode, stop after the noise and send it back to the origin at which point I observe that it does not go to the correct origin!! After homing the machine the origin is correct again.

I was wondering if anyone has some thoughts on this ?

I have attached the GCode, from what I can tell it happens at or just after Line 193.

Thanks,
Serge

 
Veröffentlicht : 20/10/2023 6:34 pm
(@cncmiller)
Beiträge: 230
Reputable Member
 

hello,
I asume you use WinPC-NC as your controller program?
Did you encounter earlier problems with your code or is this the first step in milling?
And by the way your G-code is not attached in your message.

Can't give you any suggestions on present info.

SC 1/420 + Gantry extension, Kress 1050 FME-P, NeJe 20W Laser, WinPC-NC USB v4.00, Vectric Aspire 9, SolidWorks 2021

 
Veröffentlicht : 24/10/2023 3:15 pm
(@ssozonoff)
Beiträge: 2
New Member
Themenstarter
 

Hi.

Yes sorry thats with a WinPC-NC controller + App.
What I have discovered is that despite the Specs. for the D420 Generation 3 quoting a max speed of 99mm/s the machine cant do this without loosing steps, it cant even do 70mm/s! This is simple repositioning moves without cutting anything. I have had to drop the Max speed in WinPC-NC to 50mm/s to get something stable.

It seems that the X axis is worse than than the Y and normally I see the step loss on a diagonal move. In this case a link move for the next cut.

The reason I saw this now is that there was a mismatch in the units being used by the WinPC-NC post processor in Fusion360. So the speeds in GCode where much to fast but WinPC-NC was limiting the max speed to 70mm/s based on the parameter settings. For now I have dropped this to 50mm/s.

So now I am wondering why I can achieve anything close to the max diagonal speed quoted on the website ?

Thanks,
Serge

 
Veröffentlicht : 24/10/2023 5:44 pm
Teilen: